summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-17 20:47:22 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:49:57 -0400
commit8069ff0bc4fc90a2ea2a56a0e67d11e8edec79f6 (patch)
tree9f88674689002ba507db3ed037dc7a5520cb05ea /gnu/packages/gnome.scm
parent80f6f9d86e1b3006da427933db4ab584d210f8ec (diff)
downloadguix-patches-8069ff0bc4fc90a2ea2a56a0e67d11e8edec79f6.tar
guix-patches-8069ff0bc4fc90a2ea2a56a0e67d11e8edec79f6.tar.gz
gnu: nautilus: Update to 3.34.2.
* gnu/packages/gnome.scm (nautilus): Update to 3.34.2. [arguments]: Add 'skip-gtk-update-icon-cache' phase. [native-inputs]: Remove gtk+:bin. (cherry picked from commit ba1d88e83aeb2e6b3ec4006c901f687235cd63c0)
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 674e3d3899..d29e1778c1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7464,7 +7464,7 @@ shared object databases, search tools and indexing.")
(define-public nautilus
(package
(name "nautilus")
- (version "3.32.3")
+ (version "3.34.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -7472,17 +7472,24 @@ shared object databases, search tools and indexing.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1x9crzbj6rrrf8w5dkcx0c14j40byr4ijpzkwd5dcrbfvvdy1r01"))))
+ "19zqwq4qyyncc5wq3xls0f7rsavnw741k336p2h7kx35p4kf41mv"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "build-aux/meson/postinstall.py"
+ (("gtk-update-icon-cache") "true"))
+ #t)))
;; XXX: FAIL: check-nautilus
;; Settings schema 'org.gnome.nautilus.preferences' is not installed
#:tests? #f))
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
- ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)
("pkg-config" ,pkg-config)))