summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-23 11:22:45 +0200
committerMarius Bakke <marius@gnu.org>2020-05-26 22:36:11 +0200
commit682ae6f947ca3efb902f8c7ae25914e34cb74e8e (patch)
tree8a816918b9fc1c35c04c8fff4a2bb6f28f533dc4 /gnu/packages/gnome.scm
parent76623b6703ce3d5780d742fd7b5285aa0cf7041d (diff)
downloadguix-patches-682ae6f947ca3efb902f8c7ae25914e34cb74e8e.tar
guix-patches-682ae6f947ca3efb902f8c7ae25914e34cb74e8e.tar.gz
gnu: mutter: Fix build with Mesa 20.
* gnu/packages/gnome.scm (mutter)[arguments]: Add #:phases.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e0e1ed1804..566c31f415 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6084,7 +6084,21 @@ to display dialog boxes from the commandline and shell scripts.")
;; the remaining flags are needed for the bundled cogl
(string-append "-Dopengl_libname="
(assoc-ref %build-inputs "mesa")
- "/lib/libGL.so"))))
+ "/lib/libGL.so"))
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'fix-build-with-mesa-20
+ (lambda _
+ ;; Mimic upstream commit a444a4c5f58ea516ad for
+ ;; compatibility with Mesa 20. Remove for 3.36.
+ (substitute* '("src/backends/meta-egl-ext.h"
+ "src/backends/meta-egl.c"
+ "src/backends/meta-egl.h")
+ (("#include <EGL/eglext\\.h>" all)
+ (string-append all "\n#include <EGL/eglmesaext.h>")))
+ (substitute* "cogl/cogl/meson.build"
+ (("#include <EGL/eglext\\.h>" all)
+ (string-append all "\\n#include <EGL/eglmesaext.h>")))
+ #t)))))
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.