summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-01-27 16:28:22 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-01-27 16:28:22 +0100
commit5e9b141675e46da042b5268f405afa5b272d6415 (patch)
treede0f9b5dec6e09f0188e008d1aacb5bbe179f045 /gnu/packages/gnome.scm
parentb89d8a4271c8ef02c9b1e51a2c86341cdc09c760 (diff)
downloadguix-patches-5e9b141675e46da042b5268f405afa5b272d6415.tar
guix-patches-5e9b141675e46da042b5268f405afa5b272d6415.tar.gz
gnu: evolution-data-server: Fix build failure against ICU 60.
* gnu/packages/gnome.scm (evolution-data-server)[arguments]: Add CMAKE_CXX_FLAGS=-std=gnu++11 to #:configure-flags.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8ddc022546..d460915a36 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4891,6 +4891,9 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
"-DENABLE_GOOGLE=OFF" ;disable Google Contacts support
"-DENABLE_GOOGLE_AUTH=OFF" ;disable Google authentication
"-DENABLE_VALA_BINDINGS=ON"
+ ;; FIXME: Building against ICU 60 requires C++11 or higher. Remove
+ ;; this when our default compiler is >= GCC6.
+ "-DCMAKE_CXX_FLAGS=-std=gnu++11"
"-DENABLE_INTROSPECTION=ON") ;required for Vala bindings
#:phases
(modify-phases %standard-phases