summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-21 13:56:06 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-21 15:01:46 +0100
commit5dc6d5ce9997e4caf66d154f91c3695e02e5386f (patch)
tree088272b0f6868d4a973c724729758f7d4e6c0089 /gnu/packages/gnome.scm
parenta19fb6a43648f6a3556d8139794ebd8646e792b8 (diff)
downloadguix-patches-5dc6d5ce9997e4caf66d154f91c3695e02e5386f.tar
guix-patches-5dc6d5ce9997e4caf66d154f91c3695e02e5386f.tar.gz
gnu: upower: Install 'dbus-1/system.d/org.freedesktop.UPower.conf' to etc/.
Fixes <https://bugs.gnu.org/39203>. Reported by Jesse Gibbons <jgibbons2357@gmail.com>. * gnu/packages/gnome.scm (upower)[source]: Add 'modules' and 'snippet'.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8b7ac13457..c304bdbc9b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
@@ -4175,7 +4175,20 @@ faster results and to avoid unnecessary server load.")
(sha256
(base32
"1vxxvmz2cxb1qy6ibszaz5bskqdy9nd9fxspj9fv3gfmrjzzzdb4"))
- (patches (search-patches "upower-builddir.patch"))))
+ (patches (search-patches "upower-builddir.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Upstream commit
+ ;; <https://cgit.freedesktop.org/upower/commit/?id=18457c99b68786cd729b315723d680e6860d9cfa>
+ ;; moved 'dbus-1/system.d' from etc/ to share/. However,
+ ;; 'dbus-configuration-directory' in (gnu services dbus)
+ ;; expects it in etc/. Thus, move it back to its previous
+ ;; location.
+ (substitute* "src/Makefile.in"
+ (("^dbusconfdir =.*$")
+ "dbusconfdir = $(sysconfdir)/dbus-1/system.d\n"))
+ #t))))
(build-system glib-or-gtk-build-system)
(arguments
'( ;; The tests want to contact the system bus, which can't be done in the