summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-02-24 09:09:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-02-24 11:05:51 +0200
commit5213b6975aef23cca2fc9dd8d9f201907e5548f4 (patch)
treef1f8bced7c7666b1d5939ab71037b500e8354bcc /gnu/packages/gnome.scm
parent08048ce994a52440162c3a5fc9bf3f17c9affa24 (diff)
downloadguix-patches-5213b6975aef23cca2fc9dd8d9f201907e5548f4.tar
guix-patches-5213b6975aef23cca2fc9dd8d9f201907e5548f4.tar.gz
gnu: librsvg-next: Update dependencies.
* gnu/packages/gnome.scm (librsvg-next-source): Update rust dependencies.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm25
1 files changed, 16 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c64b182869..af45ceb505 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2181,7 +2181,15 @@ from forcing GEXP-PROMISE."
;; The following crate(s) are needed in addition to the ones replaced:
(begin
(invoke
- "tar" "xvf" #+(package-source rust-autocfg-0.1) "-C" "vendor"))
+ "tar" "xvf" #+(package-source rust-autocfg-0.1) "-C" "vendor")
+ (invoke
+ "tar" "xvf" #+(package-source rust-proc-macro2-0.4) "-C" "vendor")
+ (invoke
+ "tar" "xvf" #+(package-source rust-quote-0.6) "-C" "vendor")
+ (invoke
+ "tar" "xvf" #+(package-source rust-unicode-xid-0.1) "-C" "vendor")
+ (invoke
+ "tar" "xvf" #+(package-source rust-maybe-uninit-2.0) "-C" "vendor"))
(for-each
(lambda (crate)
(delete-file-recursively (string-append "vendor/" (car crate)))
@@ -2246,7 +2254,7 @@ from forcing GEXP-PROMISE."
;; locale_config 0.3
("log" . #+(package-source rust-log-0.4))
("mac" . #+(package-source rust-mac-0.1))
-;; malloc_buf 0.0
+ ("malloc_buf" . #+(package-source rust-malloc-buf-0.0))
;; markup5ever 0.9
("matches" . #+(package-source rust-matches-0.1))
;; matrixmultiply 0.2
@@ -2257,12 +2265,12 @@ from forcing GEXP-PROMISE."
("nodrop" . #+(package-source rust-nodrop-0.1))
("num-complex" . #+(package-source rust-num-complex-0.2))
("num-integer" . #+(package-source rust-num-integer-0.1))
-;; num-rational 0.2
+ ("num-rational" . #+(package-source rust-num-rational-0.2))
("num-traits" . #+(package-source rust-num-traits-0.2))
("num_cpus" . #+(package-source rust-num-cpus-1.10))
-;; objc 0.2
-;; objc-foundation 0.1
-;; objc_id 0.1
+ ("objc" . #+(package-source rust-objc-0.2))
+ ("objc-foundation" . #+(package-source rust-objc-foundation-0.1))
+ ("objc_id" . #+(package-source rust-objc-id-0.1))
;; pango 0.7
;; pango-sys 0.9
;; pangocairo 0.8
@@ -2308,7 +2316,7 @@ from forcing GEXP-PROMISE."
("siphasher" . #+(package-source rust-siphasher-0.2))
("smallvec" . #+(package-source rust-smallvec-0.6))
("string_cache" . #+(package-source rust-string-cache-0.7))
- ;("string_cache_codegen" . #+(package-source rust-string-cache-codegen-0.4))
+ ("string_cache_codegen" . #+(package-source rust-string-cache-codegen-0.4))
("string_cache_shared" . #+(package-source rust-string-cache-shared-0.3))
("syn" . #+(package-source rust-syn-1.0))
("tendril" . #+(package-source rust-tendril-0.4))
@@ -2327,8 +2335,7 @@ from forcing GEXP-PROMISE."
("winapi-i686-pc-windows-gnu" . #+(package-source rust-winapi-i686-pc-windows-gnu-0.4))
("winapi-util" . #+(package-source rust-winapi-util-0.1))
("winapi-x86_64-pc-windows-gnu" . #+(package-source rust-winapi-x86-64-pc-windows-gnu-0.4))
-;; xml-rs 0.8
- )))
+ ("xml-rs" . #+(package-source rust-xml-rs-0.8)))))
(format #t "Replacing vendored crates in the tarball and repacking ...~%")
(force-output)
(invoke "tar" "cfa" #$output