summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-04-27 05:23:31 -0400
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-04-30 16:12:41 +0200
commit2fd6484ad3486c3f8387e35d3388e59f4ea5053a (patch)
treea8d7bf6b5963da842162c8d5a813404b891b1cdf /gnu/packages/gnome.scm
parentd5fdd88739c609987c914a01d2a71d6e3935fec3 (diff)
downloadguix-patches-2fd6484ad3486c3f8387e35d3388e59f4ea5053a.tar
guix-patches-2fd6484ad3486c3f8387e35d3388e59f4ea5053a.tar.gz
gnu: libsoup: Adjust inputs.
* gnu/packages/gnome.scm (libsoup)[inputs]: Add samba and move glib-networking to ... [propagated-inputs]: ... here. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 28d928228d..d080e53ef0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4927,16 +4927,17 @@ libxml to ease remote use of the RESTful API.")
("gnutls" ,gnutls) ;for 'certtool'
("httpd" ,httpd)))
(propagated-inputs
- ;; libsoup-2.4.pc refers to all these.
+ ;; libsoup-2.4.pc refers to all of these (except where otherwise noted)
`(("brotli" ,google-brotli)
("glib" ,glib)
+ ("glib-networking" ,glib-networking) ; for GIO runtime modules
("libpsl" ,libpsl)
("libxml2" ,libxml2)
("sqlite" ,sqlite)
("zlib" ,zlib)))
(inputs
- `(("glib-networking" ,glib-networking)
- ("mit-krb5" ,mit-krb5)))
+ `(("mit-krb5" ,mit-krb5)
+ ("ntlm_auth" ,samba))) ; For ntlm_auth support
(home-page "https://live.gnome.org/LibSoup/")
(synopsis "GLib-based HTTP Library")
(description