summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-10 13:14:51 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-11 11:52:50 -0400
commit1a43e0067b6754b2b1305376c66e8c59eccc89ea (patch)
treeaf68e44787f249d37fbe6ebda975ce5e4a02c0bf /gnu/packages/gnome.scm
parentcbbb5aa9d4ee51c54f56ebef79f7c3552308f32b (diff)
downloadguix-patches-1a43e0067b6754b2b1305376c66e8c59eccc89ea.tar
guix-patches-1a43e0067b6754b2b1305376c66e8c59eccc89ea.tar.gz
gnu: gnome-themes-standard: Deprecate in favor of gnome-themes-extra.
* gnu/packages/gnome.scm (gnome-themes-standard): Mark as deprecated by gnome-themes-extra. (gnome)[inputs]: Remove gnome-themes-extra.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm40
1 files changed, 3 insertions, 37 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3c4251286b..291bd8c3ac 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4321,42 +4321,6 @@ engineering.")
"Drawing is a basic image editor aiming at the GNOME desktop.")
(license license:gpl3+)))
-(define-public gnome-themes-standard
- (package
- (name "gnome-themes-standard")
- (version "3.22.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/" name "-"
- version ".tar.xz"))
- (sha256
- (base32
- "0smmiamrgcgf5sa88bsn8hwmvsyx4gczzs359nwxbkv14b2qgp31"))))
- (build-system gnu-build-system)
- (arguments
- '(#:configure-flags
- ;; Don't create 'icon-theme.cache'.
- (let* ((coreutils (assoc-ref %build-inputs "coreutils"))
- (true (string-append coreutils "/bin/true")))
- (list (string-append "GTK_UPDATE_ICON_CACHE=" true)))))
- (inputs
- `(("gtk+" ,gtk+)
- ("gtk+-2" ,gtk+-2)
- ("librsvg" ,librsvg)
- ("libxml2" ,libxml2)
- ("glib" ,glib)))
- (native-inputs
- `(("intltool" ,intltool)
- ("glib:bin" ,glib "bin")
- ("pkg-config" ,pkg-config)))
- (home-page "https://launchpad.net/gnome-themes-standard")
- (synopsis "Default GNOME 3 themes")
- (description
- "The default GNOME 3 themes (Adwaita and some accessibility themes).")
- (license license:lgpl2.1+)))
-
(define-public seahorse
(package
(name "seahorse")
@@ -9565,7 +9529,6 @@ world.")
("dconf" ,dconf)
("desktop-file-utils" ,desktop-file-utils)
("gnome-default-applications" ,gnome-default-applications)
- ("gnome-themes-standard" ,gnome-themes-standard)
("gst-plugins-base" ,gst-plugins-base)
("gst-plugins-good" ,gst-plugins-good)
("gucharmap" ,gucharmap)
@@ -11579,6 +11542,9 @@ versions of Adwaita, Adwaita-dark and HighContrast themes. It also provides
index files needed for Adwaita to be used outside of GNOME.")
(license license:lgpl2.1+)))
+(define-public gnome-themes-standard
+ (deprecated-package "gnome-themes-standard" gnome-themes-extra))
+
(define-public gnote
(package
(name "gnote")