summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-03-07 16:33:24 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-03-08 08:50:19 +0100
commitc4195a1078336281592394ff9585c85e8d2f6e6d (patch)
tree2b05ba6d2dcf77ebbacbd62578a912704aab0a99 /gnu/packages/gnome-xyz.scm
parentf4a435cccad892b8b7892ce9795e5cf039c1d2fe (diff)
downloadguix-patches-c4195a1078336281592394ff9585c85e8d2f6e6d.tar
guix-patches-c4195a1078336281592394ff9585c85e8d2f6e6d.tar.gz
gnu: orchis-theme: Build all versions.
* gnu/packages/gnome-xyz.scm (orchis-theme)[arguments]: Add #:configure-flags. Use them in 'install phase.
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index de43d255f0..f73001f64b 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -811,19 +811,25 @@ dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
#t))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; no tests
+ `(#:configure-flags (list
+ "--dest" (string-append
+ (assoc-ref %outputs "out")
+ "/share/themes")
+ "--theme" "all"
+ "--radio-color")
+ #:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
(delete 'bootstrap)
(delete 'configure)
(replace 'build (lambda _ (invoke "./parse-sass.sh")))
(replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((themes (string-append (assoc-ref outputs "out")
- "/share/themes")))
- (mkdir-p themes)
- (invoke "./install.sh" "-d" themes)
- #t))))))
+ (lambda* (#:key configure-flags #:allow-other-keys)
+ (mkdir-p
+ (cadr (or (member "--dest" configure-flags)
+ (member "-d" configure-flags))))
+ (apply invoke "./install.sh" configure-flags)
+ #t)))))
(inputs
`(("gtk-engines" ,gtk-engines)))
(native-inputs