summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2019-12-08 21:12:50 +0100
committerEfraim Flashner <efraim@flashner.co.il>2019-12-20 08:59:47 +0200
commit5be0ff33ff05c7764159b549a5f5d21ee0b32a6e (patch)
tree8b5a4f1d029fc8d4f1609b0a18a4a41c6b66df3c /gnu/packages/gnome-xyz.scm
parentae4e141452a0e0ce126ae5b12a21b87999a26535 (diff)
downloadguix-patches-5be0ff33ff05c7764159b549a5f5d21ee0b32a6e.tar
guix-patches-5be0ff33ff05c7764159b549a5f5d21ee0b32a6e.tar.gz
gnu: Add gnome-shell-extension-hide-app-icon.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-hide-app-icon): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index ebd8dd01e8..4b5e07a1a0 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -151,6 +151,52 @@ faster window switching.")
(home-page "https://micheleg.github.io/dash-to-dock/")
(license license:gpl2+)))
+(define-public gnome-shell-extension-hide-app-icon
+ (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
+ (revision "0"))
+ (package
+ (name "gnome-shell-extension-hide-app-icon")
+ (version (git-version "2.7" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no test target
+ #:make-flags (list (string-append "EXTENSIONS_DIR="
+ (assoc-ref %outputs "out")
+ "/share/gnome-shell/extensions"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (copy-recursively "hide-app-icon@mrapp.sourceforge.com/"
+ (string-append out "/share/gnome-shell/extensions"))
+ #t))))))
+ (native-inputs
+ `(("glib" ,glib "bin")
+ ("intltool" ,intltool)))
+ (propagated-inputs
+ `(("glib" ,glib)))
+ (synopsis "Hide app icon from GNOME's panel")
+ (description "This extension allows to hide the icon and/or title of the
+currently focused application in the top panel of the GNOME shell.")
+ (home-page "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
+ (license
+ ;; README.md and LICENSE.txt disagree -- the former claims v3, the
+ ;; latter v2. No mention of "or later" in either place or in the code.
+ (list license:gpl2
+ license:gpl3)))))
+
(define-public gnome-shell-extension-dash-to-panel
(package
(name "gnome-shell-extension-dash-to-panel")