summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-02-17 11:16:40 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-03-06 18:28:04 +0100
commit3483886cf47199eaf3f11fb132605e7f39e9e12d (patch)
treee9d21fd62f6108511d64234c720a49a593f3434e /gnu/packages/gnome-xyz.scm
parenta3084e1e06c30179bd75af2a0badd8a7ac0485f7 (diff)
downloadguix-patches-3483886cf47199eaf3f11fb132605e7f39e9e12d.tar
guix-patches-3483886cf47199eaf3f11fb132605e7f39e9e12d.tar.gz
gnu: Add orchis-theme.
* gnu/packages/gnome-xyz.scm (orchis-theme): New variable.
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index aa7949478c..e481a10e11 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -781,6 +781,64 @@ dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
(define-public numix-theme
(deprecated-package "numix-theme" numix-gtk-theme))
+(define-public orchis-theme
+ (package
+ (name "orchis-theme")
+ (version "2021-01-22")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/vinceliuice/Orchis-theme")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m0wilvrscg2xnkp6a90j0iccxd8ywvfpza1345sc6xmml9gvjzc"))
+ (modules '((guix build utils)
+ (ice-9 regex)
+ (srfi srfi-26)))
+ (snippet
+ '(begin
+ (for-each
+ (lambda (f)
+ (let* ((r (make-regexp "\\.scss"))
+ (f* (regexp-substitute #f (regexp-exec r f) 'pre ".css")))
+ (if (file-exists? f*)
+ (delete-file f*))))
+ (find-files "." ".*\\.scss"))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'build (lambda _ (invoke "./parse-sass.sh")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((themes (string-append (assoc-ref outputs "out")
+ "/share/themes")))
+ (mkdir-p themes)
+ (invoke "./install.sh" "-d" themes)
+ #t))))))
+ (inputs
+ `(("gtk-engines" ,gtk-engines)))
+ (native-inputs
+ `(;("coreutils" ,coreutils)
+ ("gtk+" ,gtk+)
+ ("sassc" ,sassc)))
+ (home-page "https://github.com/vinceliuice/Orchis-theme")
+ (synopsis "Material Design theme for a wide range of environments")
+ (description "Orchis is a Material Design them for GNOME/GTK based
+desktop environments. It is based on materia-theme and adds more color
+variants.")
+ (license (list license:gpl3 ; Claimed by README.md.
+ license:lgpl2.1 ; Some style sheets.
+ license:cc-by-sa4.0)))) ; Some icons
+
(define-public markets
(package
(name "markets")