summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorCharles <charles.b.jackson@protonmail.com>2022-01-19 10:19:24 -0600
committerMathieu Othacehe <othacehe@gnu.org>2022-01-20 14:26:03 +0100
commit30ae72b7986dbb0180ab48877cf8cd7cceb17c17 (patch)
treed9fe78cfa44c82334e92f106ff89a0a7290ac734 /gnu/packages/gnome-xyz.scm
parent12aeeea4c4d51a9ffe699cc8205d0f4213b484c1 (diff)
downloadguix-patches-30ae72b7986dbb0180ab48877cf8cd7cceb17c17.tar
guix-patches-30ae72b7986dbb0180ab48877cf8cd7cceb17c17.tar.gz
gnu: gnome-xyz: Add gnome-shell-extension-blur-my-shell.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-blur-my-shell): New Variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 17c6bd78e8..7f67f12672 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -861,6 +861,46 @@ position when the mouse is moved rapidly.")
animation of closing windowed applications.")
(license license:gpl3)))
+(define-public gnome-shell-extension-blur-my-shell
+ (package
+ (name "gnome-shell-extension-blur-my-shell")
+ (version "27")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aunetx/blur-my-shell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l318lgc2zrp8fskabiv28knwp3b5i2y8bd3164da4pkf1jsl468"))
+ (snippet
+ '(begin (delete-file "src/schemas/gschemas.compiled")))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ '(("." ,(string-append
+ "share/gnome-shell/extensions/"
+ "blur-my-shell@aunetx")
+ #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+ "\\.xml$" "\\.compiled$")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'cd-src
+ (lambda _ (chdir "src")))
+ (add-before 'install 'compile-schemas
+ (lambda _
+ (with-directory-excursion "schemas"
+ (invoke "glib-compile-schemas" ".")))))))
+ (native-inputs
+ (list (list glib "bin"))) ; for glib-compile-schemas
+ (home-page "https://github.com/aunetx/blur-my-shell")
+ (synopsis "Blurs different parts of the GNOME Shell")
+ (description "Blur My Shell adds a blur look to different parts of the
+GNOME Shell, including the top panel, dash and overview.")
+ (license license:gpl3)))
+
(define-public arc-theme
(package
(name "arc-theme")