summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-24 15:28:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-24 20:50:44 +0200
commit2aab587f842908a886e3bd08b028885dddd650e0 (patch)
tree87c0723a9ae2c69ab6920d90b6e87ad8510492fe /gnu/packages/gnome-xyz.scm
parent5664bcdcb0e4c10dfe48dd5e4730fc3c746a21e2 (diff)
parent65c46e79e0495fe4d32f6f2725d7233fff10fd70 (diff)
downloadguix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar
guix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index c7e7394f43..21192acdd6 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -781,6 +781,70 @@ dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
(define-public numix-theme
(deprecated-package "numix-theme" numix-gtk-theme))
+(define-public orchis-theme
+ (package
+ (name "orchis-theme")
+ (version "2021-02-28")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/vinceliuice/Orchis-theme")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qp3phiza93qllrjm5xjjca5b7l2sbng8c382khy9m97grxvcq0y"))
+ (modules '((guix build utils)
+ (ice-9 regex)
+ (srfi srfi-26)))
+ (snippet
+ '(begin
+ (for-each
+ (lambda (f)
+ (let* ((r (make-regexp "\\.scss"))
+ (f* (regexp-substitute #f (regexp-exec r f) 'pre ".css")))
+ (if (file-exists? f*)
+ (delete-file f*))))
+ (find-files "." ".*\\.scss"))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list
+ "--dest" (string-append
+ (assoc-ref %outputs "out")
+ "/share/themes")
+ "--theme" "all"
+ "--radio-color")
+ #:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'build (lambda _ (invoke "./parse-sass.sh")))
+ (replace 'install
+ (lambda* (#:key configure-flags #:allow-other-keys)
+ (mkdir-p
+ (cadr (or (member "--dest" configure-flags)
+ (member "-d" configure-flags))))
+ (apply invoke "./install.sh" configure-flags)
+ #t)))))
+ (inputs
+ `(("gtk-engines" ,gtk-engines)))
+ (native-inputs
+ `(;("coreutils" ,coreutils)
+ ("gtk+" ,gtk+)
+ ("sassc" ,sassc)))
+ (home-page "https://github.com/vinceliuice/Orchis-theme")
+ (synopsis "Material Design theme for a wide range of environments")
+ (description "Orchis is a Material Design them for GNOME/GTK based
+desktop environments. It is based on materia-theme and adds more color
+variants.")
+ (license (list license:gpl3 ; According to COPYING.
+ license:lgpl2.1 ; Some style sheets.
+ license:cc-by-sa4.0)))) ; Some icons
+
(define-public markets
(package
(name "markets")