summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-01-02 23:45:06 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-01-07 19:34:15 +0100
commit0759cde4fe97b7dc467ea7ce7b121a9a0e44a78a (patch)
treee7a526e703dfe93e5c248bed745690fc07652db9 /gnu/packages/gnome-xyz.scm
parent67b1ef5f65f4aeb302c5ec34890111c076b4e524 (diff)
downloadguix-patches-0759cde4fe97b7dc467ea7ce7b121a9a0e44a78a.tar
guix-patches-0759cde4fe97b7dc467ea7ce7b121a9a0e44a78a.tar.gz
gnu: papirus-icon-theme: Update to 20210101.
* gnu/packages/gnome-xyz.scm (papirus-icon-theme): Update to 20210101. Also use upstream versioning.
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm43
1 files changed, 20 insertions, 23 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index c97405104e..96e109ba59 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -585,23 +585,20 @@ dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
(deprecated-package "numix-theme" numix-gtk-theme))
(define-public papirus-icon-theme
- (let ((version "0.0.0") ;; The package does not use semver
- (revision "2")
- (tag "20200602"))
- (package
- (name "papirus-icon-theme")
- (version (git-version version revision tag))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/PapirusDevelopmentTeam/papirus-icon-theme")
- (commit tag)))
- (sha256
- (base32
- "0yv19kl8jr2jmh9018b1qmnq68alw84vrmb35jm462qd3qzzdgah"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
+ (package
+ (name "papirus-icon-theme")
+ (version "20210101")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PapirusDevelopmentTeam/papirus-icon-theme")
+ (commit version)))
+ (sha256
+ (base32
+ "0w6qg3zjhfvjg1gg5inranf8ianb4mrp0jm9qgi6hg87ig1rashs"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
(arguments
'(#:tests? #f
#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
@@ -610,13 +607,13 @@ dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
(delete 'bootstrap)
(delete 'configure)
(delete 'build))))
- (native-inputs
- `(("gtk+:bin" ,gtk+ "bin")))
- (home-page "https://git.io/papirus-icon-theme")
- (synopsis "Fork of Paper icon theme with a lot of new icons and a few extras")
- (description "Papirus is a fork of the icon theme Paper with a lot of new icons
+ (native-inputs
+ `(("gtk+:bin" ,gtk+ "bin")))
+ (home-page "https://git.io/papirus-icon-theme")
+ (synopsis "Fork of Paper icon theme with a lot of new icons and a few extras")
+ (description "Papirus is a fork of the icon theme Paper with a lot of new icons
and a few extra features.")
- (license license:gpl3))))
+ (license license:gpl3)))
(define-public vala-language-server
(package