summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-21 14:08:54 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-21 14:54:28 +0200
commitf2a0f03b57b102c7369a787621f5839758d814ef (patch)
tree14944861a0c344e0f2f0aaa867f150a666d74386 /gnu/packages/glib.scm
parent9644ac6f4d39492129f90188a32d5931eb30ab8d (diff)
downloadguix-patches-f2a0f03b57b102c7369a787621f5839758d814ef.tar
guix-patches-f2a0f03b57b102c7369a787621f5839758d814ef.tar.gz
gnu: gobject-introspection: Build with Meson.
The 1.60.x releases are the last ones to support Autotools. * gnu/packages/glib.scm (gobject-introspection)[build-system]: Change to MESON-BUILD-SYSTEM. [arguments]: Remove <#:parallel-build?> and <#:tests?>. [native-inputs]: Remove AUTOCONF and AUTOMAKE.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a4ae7b55bc..d8d339eebe 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -28,7 +28,6 @@
(define-module (gnu packages glib)
#:use-module (gnu packages)
- #:use-module (gnu packages autotools)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
@@ -361,15 +360,9 @@ dynamic loading, and an object system.")
"gobject-introspection-cc.patch"
"gobject-introspection-girepository.patch"
"gobject-introspection-absolute-shlib-path.patch"))))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(arguments
- `(;; The build system has at least one race condition involving Gio-2.0.gir
- ;; which causes intermittent failures, as of 1.56.0.
- #:parallel-build? #f
- ;; The patch 'gobject-introspection-absolute-shlib-path.patch' causes
- ;; some tests to fail.
- #:tests? #f
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'do-not-use-/usr/bin/env
(lambda _
@@ -384,9 +377,7 @@ dynamic loading, and an object system.")
("python" ,python-wrapper)
("zlib" ,zlib)))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("glib" ,glib "bin")
+ `(("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
(propagated-inputs
`(;; In practice, GIR users will need libffi when using