summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-29 00:53:32 -0400
committerMark H Weaver <mhw@netris.org>2018-04-10 00:44:54 -0400
commitd57d54d18907f5ed03b0e147537b853c87d62d68 (patch)
tree63179c83cf8f8d70055e1f36cb4207d11368d899 /gnu/packages/glib.scm
parentb707140bc50419a294a9fffd5d1ae18b0da81f3c (diff)
downloadguix-patches-d57d54d18907f5ed03b0e147537b853c87d62d68.tar
guix-patches-d57d54d18907f5ed03b0e147537b853c87d62d68.tar.gz
gnu: python-pygobject: Use gcc-7.
* gnu/packages/glib.scm (python-pygobject)[native-inputs]: Add gcc-7.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 499675dc88..2f789b9f9d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages enlightenment)
#:use-module (gnu packages file)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gperf)
@@ -609,7 +610,11 @@ useful for C++.")
"1zdzznrj2s1gsrv2z4r0n88fzba8zjc1n2r313xi77lhl1daja56"))))
(build-system gnu-build-system)
(native-inputs
- `(("which" ,which)
+ `(;; Use gcc-7 to work around an internal compiler error that happens
+ ;; when using gcc-5.5.0. FIXME: Try removing this when the default
+ ;; compiler is no longer gcc-5.5.0.
+ ("gcc" ,gcc-7)
+ ("which" ,which)
;for tests: dbus-run-session and glib-compile-schemas
("dbus" ,dbus)
("glib-bin" ,glib "bin")