summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-01-10 07:35:38 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-01-14 23:30:54 -0500
commitcff1927f30c00e6df5a3be5bd7cb769cd1345873 (patch)
tree5d208d32cd5dda5978dc21f448cb6c5b429beec3 /gnu/packages/glib.scm
parent974537fc4cd8045bcdce68c5ce79df35b0e17ec3 (diff)
downloadguix-patches-cff1927f30c00e6df5a3be5bd7cb769cd1345873.tar
guix-patches-cff1927f30c00e6df5a3be5bd7cb769cd1345873.tar.gz
gnu: dbus: Build documentation (manpages and html).
* gnu/packages/glib.scm (dbus)[native-inputs]: Add docbook-xml-4.4, docbook-xsl, doxygen, xmlto, libxml2, libxslt and yelp-tools. [outputs]: Add a "doc" output to hold the large HTML documentation.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index cd9b48caff..946ed2ba19 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +34,8 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages docbook)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages enlightenment)
#:use-module (gnu packages file)
#:use-module (gnu packages flex)
@@ -118,14 +121,21 @@
"sysconfdir=/tmp/dummy"
"install"))))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ;; Dependencies to generate the doc.
+ ("docbook-xml" ,docbook-xml-4.4)
+ ("docbook-xsl" ,docbook-xsl)
+ ("doxygen" ,doxygen)
+ ("xmlto" ,xmlto)
+ ("libxml2" ,libxml2) ;for XML_CATALOG_FILES
+ ("libxslt" ,libxslt)
+ ("yelp-tools" ,yelp-tools)))
(inputs
`(("expat" ,expat)
-
;; Add a dependency on libx11 so that 'dbus-launch' has support for
;; '--autolaunch'.
("libx11" ,libx11)))
-
+ (outputs '("out" "doc")) ;22 MiB of HTML doc
(home-page "https://www.freedesktop.org/wiki/Software/dbus/")
(synopsis "Message bus for inter-process communication (IPC)")
(description