summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-09-24 08:58:26 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-12-01 22:06:03 +0100
commitc3264f9e100ad6aefe5216002b68f3bfdcf6be95 (patch)
tree1152a1d83c3d5a9f7d2d9bc05f574d162c4bd3bc /gnu/packages/glib.scm
parentc3c92c456b25ffded596a42d11044f62dcc03baa (diff)
downloadguix-patches-c3264f9e100ad6aefe5216002b68f3bfdcf6be95.tar
guix-patches-c3264f9e100ad6aefe5216002b68f3bfdcf6be95.tar.gz
gnu: gobject-introspection: Make some cosmetic changes.
* gnu/packages/glib.scm (gobject-introspection): Make some cosmetic changes. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm45
1 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 43523e516d..a4fa6faefb 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -429,17 +429,20 @@ dynamic loading, and an object system.")
(package
(name "gobject-introspection")
(version "1.62.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/"
- "gobject-introspection/" (version-major+minor version)
- "/gobject-introspection-" version ".tar.xz"))
- (sha256
- (base32 "18lhglg9v6y83lhqzyifc1z0wrlawzrhzzxx0a3h1g7xaz97xvmi"))
- (patches (search-patches
- "gobject-introspection-cc.patch"
- "gobject-introspection-girepository.patch"
- "gobject-introspection-absolute-shlib-path.patch"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://gnome/sources/"
+ "gobject-introspection/" (version-major+minor version)
+ "/gobject-introspection-" version ".tar.xz"))
+ (sha256
+ (base32 "18lhglg9v6y83lhqzyifc1z0wrlawzrhzzxx0a3h1g7xaz97xvmi"))
+ (patches
+ (search-patches
+ "gobject-introspection-cc.patch"
+ "gobject-introspection-girepository.patch"
+ "gobject-introspection-absolute-shlib-path.patch"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -450,25 +453,23 @@ dynamic loading, and an object system.")
(("#!@PYTHON_CMD@")
(string-append "#!" (which "python3"))))
#t)))))
+ (native-inputs
+ `(("glib" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
(inputs
`(("bison" ,bison)
("flex" ,flex)
("glib" ,glib)
("python" ,python-wrapper)
("zlib" ,zlib)))
- (native-inputs
- `(("glib" ,glib "bin")
- ("pkg-config" ,pkg-config)))
(propagated-inputs
- `(;; In practice, GIR users will need libffi when using
- ;; gobject-introspection.
- ("libffi" ,libffi)))
+ `(("libffi" ,libffi)))
(native-search-paths
- (list (search-path-specification
- (variable "GI_TYPELIB_PATH")
- (files '("lib/girepository-1.0")))))
+ (list
+ (search-path-specification
+ (variable "GI_TYPELIB_PATH")
+ (files '("lib/girepository-1.0")))))
(search-paths native-search-paths)
- (home-page "https://wiki.gnome.org/GObjectIntrospection")
(synopsis "Generate interface introspection data for GObject libraries")
(description
"GObject introspection is a middleware layer between C libraries (using
@@ -476,7 +477,7 @@ GObject) and language bindings. The C library can be scanned at compile time
and generate a metadata file, in addition to the actual native C library. Then
at runtime, language bindings can read this metadata and automatically provide
bindings to call into the C library.")
- ; Some bits are distributed under the LGPL2+, others under the GPL2+
+ (home-page "https://wiki.gnome.org/GObjectIntrospection")
(license license:gpl2+)))
(define intltool