summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-09-24 09:30:21 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-12-01 22:06:03 +0100
commitc2c0244ec3d09d677026e0b62e5ce4f08f030f7e (patch)
tree6910f96a262e9748f4df4fb319e6ce10218afde0 /gnu/packages/glib.scm
parent0382e6a4e633d8e95954754475d0887a661c670b (diff)
downloadguix-patches-c2c0244ec3d09d677026e0b62e5ce4f08f030f7e.tar
guix-patches-c2c0244ec3d09d677026e0b62e5ce4f08f030f7e.tar.gz
gnu: gobject-introspection: Update synopsis, description, home-page and license.
* gnu/packages/glib.scm (gobject-introspection) [synopsis]: Modify. [description]: Modify. [home-page]: Modify. [license]: Modify. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index eb2d864fa5..b9625ed8d0 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -462,15 +462,19 @@ dynamic loading, and an object system.")
(variable "GI_TYPELIB_PATH")
(files '("lib/girepository-1.0")))))
(search-paths native-search-paths)
- (synopsis "Generate interface introspection data for GObject libraries")
- (description
- "GObject introspection is a middleware layer between C libraries (using
-GObject) and language bindings. The C library can be scanned at compile time
-and generate a metadata file, in addition to the actual native C library. Then
-at runtime, language bindings can read this metadata and automatically provide
-bindings to call into the C library.")
- (home-page "https://wiki.gnome.org/GObjectIntrospection")
- (license license:gpl2+)))
+ (synopsis "GObject introspection tools and libraries")
+ (description "GObject introspection is a middleware layer between
+C libraries (using GObject) and language bindings. The C library can be scanned
+at compile time and generate metadata files, in addition to the actual native
+C library. Then language bindings can read this metadata and automatically
+provide bindings to call into the C library.")
+ (home-page "https://wiki.gnome.org/Projects/GObjectIntrospection")
+ (license
+ (list
+ ;; For library.
+ license:lgpl2.0+
+ ;; For tools.
+ license:gpl2+))))
(define intltool
(package