summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-09-26 16:40:11 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-09-27 18:57:37 +0200
commit9e0cb9d79d501f36740dade2c9a5d80f955ac2bc (patch)
tree94a80e9d469ea2dcfaec6e08b229ee2fd514c071 /gnu/packages/glib.scm
parent7970127ff0817336a6de03041aea83fc0bdc9980 (diff)
downloadguix-patches-9e0cb9d79d501f36740dade2c9a5d80f955ac2bc.tar
guix-patches-9e0cb9d79d501f36740dade2c9a5d80f955ac2bc.tar.gz
gnu: Add xdg-dbus-proxy.
* gnu/packages/glib.scm (xdg-dbus-proxy): New public variable.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 77b5715eb0..a02cf3b7f3 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,6 +35,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages enlightenment)
#:use-module (gnu packages file)
#:use-module (gnu packages flex)
@@ -929,3 +931,37 @@ safe to use from any GObject-Introspectable language.
Template-GLib allows you to access properties on GObjects as well as call
simple methods via GObject-Introspection.")
(license license:lgpl2.1+)))
+
+(define-public xdg-dbus-proxy
+ (package
+ (name "xdg-dbus-proxy")
+ (version "0.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/flatpak/xdg-dbus-proxy"
+ "/releases/download/" version
+ "/xdg-dbus-proxy-" version ".tar.xz"))
+ (sha256
+ (base32
+ "03sj1h0c2l08xa8phw013fnxr4fgav7l2mkjhzf9xk3dykwxcj8p"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+
+ ;; For tests.
+ ("dbus" ,dbus)
+
+ ;; These are required to build the manual.
+ ("docbook-xml" ,docbook-xml-4.3)
+ ("docbook-xsl" ,docbook-xsl)
+ ("libxml2" ,libxml2)
+ ("xsltproc" ,libxslt)))
+ (inputs
+ `(("glib" ,glib)))
+ (home-page "https://github.com/flatpak/xdg-dbus-proxy")
+ (synopsis "D-Bus connection proxy")
+ (description
+ "xdg-dbus-proxy is a filtering proxy for D-Bus connections. It can be
+used to create D-Bus sockets inside a Linux container that forwards requests
+to the host system, optionally with filters applied.")
+ (license license:lgpl2.1+)))