summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-24 09:21:09 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:11:46 +0000
commit967f8af877b5e428d839190744b765b0d10a96b8 (patch)
treefb1eb97c0af7366ef0bd41ea0618b027160465e9 /gnu/packages/glib.scm
parent4bacf9ced94540d71f7590227fcb84d6f6eebc89 (diff)
downloadguix-patches-967f8af877b5e428d839190744b765b0d10a96b8.tar
guix-patches-967f8af877b5e428d839190744b765b0d10a96b8.tar.gz
gnu: dbus-glib: Support cross-compilation.
This allows cross-compilation to succeed when not using QEMU's transparent emulation, and the cross-compilation is not a pointless cross-compilation like x86_64 -> i686. * gnu/packages/glib.scm (dbus-glib)[arguments]: Set --with-dbus-binding-tool to a native version of "dbus-binding-tool" when cross-compiling.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index c05a57dcbf..cf54b3187a 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -562,6 +562,16 @@ translated.")
(base32
"09g8swvc95bk1z6j8sw463p2v0dqmgm2zjfndf7i8sbcyq67dr3w"))))
(build-system gnu-build-system)
+ (arguments
+ (if (%current-target-system)
+ `(#:configure-flags
+ ;; Run a native 'dbus-binding-tool' instead of a cross-compiled
+ ;; 'dbus-binding-tool' when cross-compiling.
+ ,#~(list
+ (string-append
+ "--with-dbus-binding-tool="
+ #+(file-append this-package "/bin/dbus-binding-tool"))))
+ '()))
(propagated-inputs ; according to dbus-glib-1.pc
`(("dbus" ,dbus)
("glib" ,glib)))