summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-08 02:02:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-08 19:37:47 +0100
commit8a831c6f0699953a878dae07250c17a34a6025bf (patch)
tree164bff2a52074a69c6f91d0dc3bd04ee0b72e98c /gnu/packages/glib.scm
parent6fac106491e777b997e05b215fecba11808435f4 (diff)
downloadguix-patches-8a831c6f0699953a878dae07250c17a34a6025bf.tar
guix-patches-8a831c6f0699953a878dae07250c17a34a6025bf.tar.gz
gnu: Remove more GCC ICE workarounds.
These were fixed with <https://bugs.gnu.org/31708>. * gnu/packages/glib.scm (python-pygobject, python2-pygobject)[native-inputs]: Remove GCC-7. * gnu/packages/gnome.scm (gjs)[native-inputs]: Likewise. [arguments]: Remove related phase.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 491f688c8e..cd9b48caff 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -36,7 +36,6 @@
#:use-module (gnu packages enlightenment)
#:use-module (gnu packages file)
#:use-module (gnu packages flex)
- #:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gperf)
@@ -621,11 +620,7 @@ useful for C++.")
(delete-file "tests/test_ossig.py")
#t)))))
(native-inputs
- `(;; Use gcc-7 to work around an internal compiler error that happens
- ;; when using gcc-5.5.0. FIXME: Try removing this when the default
- ;; compiler is no longer gcc-5.5.0.
- ("gcc" ,gcc-7)
- ("which" ,which)
+ `(("which" ,which)
;for tests: dbus-run-session and glib-compile-schemas
("dbus" ,dbus)
("glib-bin" ,glib "bin")
@@ -656,11 +651,7 @@ useful for C++.")
("python-pycairo" ,python2-pycairo)
("gobject-introspection" ,gobject-introspection)))
(native-inputs
- `(;; Use gcc-7 to work around an internal compiler error that happens
- ;; when using gcc-5.5.0. FIXME: Try removing this when the default
- ;; compiler is no longer gcc-5.5.0.
- ("gcc" ,gcc-7)
- ("which" ,which)
+ `(("which" ,which)
;for tests: dbus-run-session and glib-compile-schemas
("dbus" ,dbus)
("glib-bin" ,glib "bin")