summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-06 09:39:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-06 09:39:42 +0300
commit7b7bc91c3d7fba306884cd1681d12b51246c2aea (patch)
tree86c2088f5be76dd73885fb32762746f1ebd86d03 /gnu/packages/glib.scm
parent0e2251fcf8189a4f642074d3aa898221b29c3a55 (diff)
downloadguix-patches-7b7bc91c3d7fba306884cd1681d12b51246c2aea.tar
guix-patches-7b7bc91c3d7fba306884cd1681d12b51246c2aea.tar.gz
gnu: dbus: Re-introduce extended test timeout.
This reverses removing this phase in a24562af52d2f318c9e17be73393ddb4bd9e347c, which is still needed by some slower machines. * gnu/packages/glib.scm (glib)[arguments]: Add 'increase-test-timeout phase to ensure tests which don't hang also don't timeout.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 7e49fca263..2649326e5b 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -204,6 +204,12 @@ shared NFS home directories.")
#:configure-flags '("-Dman=true")
#:phases
(modify-phases %standard-phases
+ ;; Needed to pass the test phase on slower ARM and i686 machines.
+ (add-after 'unpack 'increase-test-timeout
+ (lambda _
+ (substitute* "meson.build"
+ (("(test_timeout.*) = ([[:digit:]]+)" all first second)
+ (string-append first " = " second "0")))))
(add-after 'unpack 'disable-failing-tests
(lambda _
(with-directory-excursion "glib/tests"