summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 14:27:34 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 14:57:41 -0400
commit64ef4825d5a4cb413397d435b4c0f57cf446060f (patch)
tree7efbad6c5c07cce71ff031eee2bce2690540d1b7 /gnu/packages/glib.scm
parent51bb94ffb3be46d3d50e65e0ea4716aa3a7fa0f5 (diff)
downloadguix-patches-64ef4825d5a4cb413397d435b4c0f57cf446060f.tar
guix-patches-64ef4825d5a4cb413397d435b4c0f57cf446060f.tar.gz
gnu: Add libsigc++-2.
* gnu/packages/glib.scm (libsigc++-2): New variable. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index bff6f281cd..4a2dfee552 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -631,6 +631,42 @@ by GDBus included in Glib.")
has an ease of use unmatched by other C++ callback libraries.")
(license license:lgpl3+)))
+ (define-public libsigc++-2
+ (package
+ (inherit libsigc++)
+ (name "libsigc++")
+ (version "2.9.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://gnome/sources/libsigc++/"
+ (version-major+minor version)
+ "/libsigc++-" version ".tar.xz"))
+ (sha256
+ (base32 "0zq963d0sss82q62fdfjs7l9iwbdch51albck18cb631ml0v7y8b"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "docs"
+ (substitute* (find-files "." "\\.xml$")
+ (("http://www.oasis-open.org/docbook/xml/4\\.1\\.2/")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/"))))
+ #t))
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file
+ (string-append out "/share/doc")
+ (string-append doc "/share/doc"))
+ #t))))))))
+
(define glibmm
(package
(name "glibmm")