summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-29 16:33:18 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-29 16:37:19 +0100
commit622d702f7eba30ed26a96168e17dd4fe3e31f084 (patch)
tree8663885065a90d15d04433de2ec85e25774771df /gnu/packages/glib.scm
parente53f9ce2df774dc28c9cd1a7865ad75df15379d8 (diff)
downloadguix-patches-622d702f7eba30ed26a96168e17dd4fe3e31f084.tar
guix-patches-622d702f7eba30ed26a96168e17dd4fe3e31f084.tar.gz
gnu: Add python-pygobject@3.34.
* gnu/packages/glib.scm (python-pygobject-3.34): New public variable.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index c558d9fcb6..33e569a5d3 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -708,6 +708,33 @@ useful for C++.")
("pkg-config" ,pkg-config)
("python-pytest" ,python2-pytest)))))
+;; Newer version of this core-updates package, for Lollypop.
+(define-public python-pygobject-3.34
+ (package/inherit
+ python-pygobject
+ (version "3.34.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/pygobject/"
+ (version-major+minor version)
+ "/pygobject-" version ".tar.xz"))
+ (sha256
+ (base32 "06i7ynnbvgpz0gw09zsjbvhgcp5qz4yzdifw27qjwdazg2mckql7"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'delete-broken-tests
+ (lambda _
+ (with-directory-excursion "tests"
+ (for-each
+ delete-file
+ ;; FIXME: these tests require Gdk and/or Gtk 4.
+ '("test_atoms.py"
+ "test_overrides_gtk.py")))
+ #t)))))))
+
(define-public perl-glib
(package
(name "perl-glib")