summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-14 13:13:05 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-14 15:57:40 +0200
commit5a88b8df00dfcfb3d145ca0fd30d9fd27af4af7d (patch)
tree0eee7087ac286bb8cb71f52ce6e50be4a355e120 /gnu/packages/glib.scm
parentdcd48bfd843df8ecc2c9d77d703f341771d8f815 (diff)
downloadguix-patches-5a88b8df00dfcfb3d145ca0fd30d9fd27af4af7d.tar
guix-patches-5a88b8df00dfcfb3d145ca0fd30d9fd27af4af7d.tar.gz
glib: Look up "tzdata" in 'native-inputs', not 'inputs'.
Otherwise, "tzdata" won't be found when cross-compiling and string-append will complain about types. Alternatively, "tzdata" could be moved from 'native-inputs' to 'inputs'. * gnu/packages/glib.scm (glib)[arguments]<#:phases>{pre-check}: Look up "tzdata" in 'native-inputs', not 'inputs'. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index e4ebed7e2c..01683df8c5 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -252,10 +252,11 @@ shared NFS home directories.")
(package-version python)))))
#t))
(add-before 'check 'pre-check
- (lambda* (#:key inputs outputs #:allow-other-keys)
+ (lambda* (#:key native-inputs inputs outputs #:allow-other-keys)
;; For tests/gdatetime.c.
(setenv "TZDIR"
- (string-append (assoc-ref inputs "tzdata")
+ (string-append (assoc-ref (or native-inputs inputs)
+ "tzdata")
"/share/zoneinfo"))
;; Some tests want write access there.
(setenv "HOME" (getcwd))