summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-24 13:44:26 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-26 20:13:10 +0100
commit57e7d7486ba17d7b5407ebc429ce8553460371ea (patch)
treebb9514ea3ccdb8063a4e3396b7c0e4d2e638be12 /gnu/packages/glib.scm
parent3c4bbb4c52418c8daf8b0e4605e3912685c9f44a (diff)
downloadguix-patches-57e7d7486ba17d7b5407ebc429ce8553460371ea.tar
guix-patches-57e7d7486ba17d7b5407ebc429ce8553460371ea.tar.gz
gnu: Use HTTPS for supported freedesktop.org home pages.
* gnu/packages/fontutils.scm (fontconfig)[home-page]: Use HTTPS. * gnu/packages/freedesktop.scm (python-pyxdg, accountsservice) (modem-manager, telepathy-mission-control, telepathy-mission-control) (colord-gtk, desktop-file-utils)[home-page]: Likewise. * gnu/packages/ghostscript.scm (libspectre)[home-page]: Likewise. * gnu/packages/glib.scm (dbus, dbus-glib, telepathy-glib)[home-page]: Likewise. * gnu/packages/gnome.scm (shared-mime-info, hicolor-icon-theme) (libxklavier, colord, upower)[home-page]: Likewise. * gnu/packages/gstreamer.scm (orc, python-gst)[home-page]: Likewise. * gnu/packages/libcanberra.scm (sound-theme-freedesktop)[home-page]: Likewise. * gnu/packages/libreoffice.scm (libexttextcat)[home-page]: Likewise. * gnu/packages/polkit.scm (polkit-gnome, polkit-gnome)[home-page]: Likewise. * gnu/packages/pulseaudio.scm (pavucontrol)[home-page]: Likewise. * gnu/packages/python.scm (python-dbus)[home-page]: Likewise. * gnu/packages/xdisorg.scm (startup-notification)[home-page]: Likewise.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index d32472b85e..45d0d891c4 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -124,7 +124,7 @@
;; '--autolaunch'.
("libx11" ,libx11)))
- (home-page "http://dbus.freedesktop.org/")
+ (home-page "https://www.freedesktop.org/wiki/Software/dbus/")
(synopsis "Message bus for inter-process communication (IPC)")
(description
"D-Bus is a message bus system, a simple way for applications to
@@ -461,7 +461,7 @@ translated.")
(native-inputs
`(("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
- (home-page "http://dbus.freedesktop.org/doc/dbus-glib/")
+ (home-page "https://dbus.freedesktop.org/doc/dbus-glib/")
(synopsis "D-Bus GLib bindings")
(description
"GLib bindings for D-Bus. The package is obsolete and superseded
@@ -662,7 +662,7 @@ useful for C++.")
`(("dbus" ,dbus)
("dbus-glib" ,dbus-glib)
("glib" ,glib)))
- (home-page "http://telepathy.freedesktop.org/wiki/")
+ (home-page "https://telepathy.freedesktop.org/wiki/")
(synopsis "GLib Real-time communications framework over D-Bus")
(description "Telepathy is a flexible, modular communications framework
that enables real-time communication over D-Bus via pluggable protocol