summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-12-08 11:00:11 +0100
committerLudovic Courtès <ludo@gnu.org>2020-12-08 11:00:11 +0100
commit52ef5b384786b4a2f7031ee26ef6b196bc22f912 (patch)
treee6ae8ab9904419044045110c7b97de0d49051d6d /gnu/packages/glib.scm
parenta350523556f2a412375737aee7f8c0407e885480 (diff)
downloadguix-patches-52ef5b384786b4a2f7031ee26ef6b196bc22f912.tar
guix-patches-52ef5b384786b4a2f7031ee26ef6b196bc22f912.tar.gz
gnu: glib: Remove replacement with GIO appinfo patch.
* gnu/packages/glib.scm (glib)[replacement]: Remove. [source]: Add "glib-appinfo-watch.patch". (glib-with-gio-patch): Remove.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index d1521b2508..a37369c49a 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -172,7 +172,6 @@ shared NFS home directories.")
(package
(name "glib")
(version "2.62.6")
- (replacement glib-with-gio-patch)
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/"
@@ -181,7 +180,8 @@ shared NFS home directories.")
(sha256
(base32
"174bsmbmcvaw69ff9g60q5sx0fn23rkhqcwqz17h5s7sprps4kqh"))
- (patches (search-patches "glib-tests-timer.patch"))
+ (patches (search-patches "glib-appinfo-watch.patch"
+ "glib-tests-timer.patch"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -379,16 +379,6 @@ dynamic loading, and an object system.")
(home-page "https://developer.gnome.org/glib/")
(license license:lgpl2.1+)))
-(define glib-with-gio-patch
- ;; GLib with a fix for <https://bugs.gnu.org/35594>.
- ;; TODO: Fold into 'glib' above in the next rebuild cycle.
- (package
- (inherit glib)
- (source (origin
- (inherit (package-source glib))
- (patches (cons (search-patch "glib-appinfo-watch.patch")
- (origin-patches (package-source glib))))))))
-
(define-public glib-with-documentation
;; glib's doc must be built in a separate package since it requires gtk-doc,
;; which in turn depends on glib.