summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-11-19 22:24:57 +0100
committerLudovic Courtès <ludo@gnu.org>2020-11-19 22:36:03 +0100
commit4078b9acffa7e6e119bd3cd8dea720d1ae807dfb (patch)
tree4412c4122a4beca06dec0265a2ac1524efb24adb /gnu/packages/glib.scm
parent55d095c653e8fda73ad111c067dece66c31a49e0 (diff)
downloadguix-patches-4078b9acffa7e6e119bd3cd8dea720d1ae807dfb.tar
guix-patches-4078b9acffa7e6e119bd3cd8dea720d1ae807dfb.tar.gz
gnu: dbus: Remove replacement.
* gnu/packages/glib.scm (dbus)[replacement]: Remove. [source]: Add "dbus-CVE-2020-12049.patch". (dbus/fixed): Remove.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 845ab09b04..3f5dd936d2 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
@@ -90,7 +90,6 @@
(package
(name "dbus")
(version "1.12.16")
- (replacement dbus/fixed)
(source (origin
(method url-fetch)
(uri (string-append
@@ -99,7 +98,8 @@
(sha256
(base32
"107ckxaff1cv4q6kmfdi2fb1nlsv03312a7kf6lb4biglhpjv8jl"))
- (patches (search-patches "dbus-helper-search-path.patch"))))
+ (patches (search-patches "dbus-CVE-2020-12049.patch"
+ "dbus-helper-search-path.patch"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -167,15 +167,6 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
shared NFS home directories.")
(license license:gpl2+))) ; or Academic Free License 2.1
-;; Replacement package to fix CVE-2020-12049.
-(define dbus/fixed
- (package
- (inherit dbus)
- (source (origin
- (inherit (package-source dbus))
- (patches (append (search-patches "dbus-CVE-2020-12049.patch")
- (origin-patches (package-source dbus))))))))
-
(define glib
(package
(name "glib")