summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-29 13:54:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-29 22:52:55 +0300
commit3fced772e34cb332f6299411cd6501eadef760cb (patch)
tree3b8ab865af08ca1dfef6312b197ecc135b588492 /gnu/packages/glib.scm
parentc3c7ca7603ee177d64828aa27a6b634c29cd8361 (diff)
downloadguix-patches-3fced772e34cb332f6299411cd6501eadef760cb.tar
guix-patches-3fced772e34cb332f6299411cd6501eadef760cb.tar.gz
gnu: python-pygobject: Extend test timeout.
* gnu/packages/glib.scm (python-pygobject)[arguments]: Replace check phase and extend the test timeout.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index f0328498e4..d1d0f5b273 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -801,6 +801,14 @@ useful for C++.")
'("test_atoms.py" "test_overrides_gtk.py"))
#t)))))
(build-system meson-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; The default 90 seconds can be too low on slower machines.
+ (invoke "meson" "test" "--timeout-multiplier" "5")))))))
(native-inputs
`(("glib-bin" ,glib "bin")
("pkg-config" ,pkg-config)