summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-15 13:48:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-20 22:49:31 +0200
commit377bd155ea4d8de5dc0bf6ee6cd46d8aff16a769 (patch)
treeeb0c20a9bd9e37959c3bd6e8d16d82a6e25725f8 /gnu/packages/glib.scm
parent28618b05f002720bc56bae76659717a0eba4dd8b (diff)
downloadguix-patches-377bd155ea4d8de5dc0bf6ee6cd46d8aff16a769.tar
guix-patches-377bd155ea4d8de5dc0bf6ee6cd46d8aff16a769.tar.gz
gnu: dbus: Fix CVE-2019-12749.
* gnu/packages/patches/dbus-CVE-2019-12749.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/glib.scm (dbus)[replacement]: New field. (dbus/fixed): New variable.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 7af7c86853..d75b963794 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -80,6 +80,7 @@
(package
(name "dbus")
(version "1.12.12")
+ (replacement dbus/fixed)
(source (origin
(method url-fetch)
(uri (string-append
@@ -146,6 +147,14 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
shared NFS home directories.")
(license license:gpl2+))) ; or Academic Free License 2.1
+(define dbus/fixed
+ (package
+ (inherit dbus)
+ (source (origin
+ (inherit (package-source dbus))
+ (patches (append (search-patches "dbus-CVE-2019-12749.patch")
+ (origin-patches (package-source dbus))))))))
+
(define glib
(package
(name "glib")