summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2019-08-20 01:12:11 +0200
committerLudovic Courtès <ludo@gnu.org>2019-08-27 12:46:00 +0200
commit19d0554fd41039e0baba04623bb5d049ac47de21 (patch)
tree2f3d2efae6238a2dd864fdf83582f06366100c07 /gnu/packages/glib.scm
parent30e7c03aaedd248c57a7d92ced9963fed058cc53 (diff)
downloadguix-patches-19d0554fd41039e0baba04623bb5d049ac47de21.tar
guix-patches-19d0554fd41039e0baba04623bb5d049ac47de21.tar.gz
gnu: Add template-glib.
* gnu/packages/glib.scm (template-glib): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index ab9ed0b1bf..77b5715eb0 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -891,3 +892,40 @@ main loop, simply get a connection to the bus via the methods in
@code{Net::DBus::GLib} rather than the usual @code{Net::DBus} module. Every
other API remains the same.")
(license license:gpl2+)))
+
+(define-public template-glib
+ (package
+ (name "template-glib")
+ (version "3.32.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1g0zx0sxpw8kqp7p3sgl9kngaqrg9xl6cir24nrahks0vgsk98rr"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags '("-D" "enable_gtk_doc=true")))
+ (inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)))
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("glib:bin" ,glib "bin") ;; For glib-mkenums
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (home-page "https://gitlab.gnome.org/GNOME/template-glib")
+ (synopsis "Library for template expansion")
+ (description
+ "Template-GLib is a library to help you generate text based on a template and
+user defined state. Template-GLib does not use a language runtime, so it is
+safe to use from any GObject-Introspectable language.
+
+Template-GLib allows you to access properties on GObjects as well as call
+simple methods via GObject-Introspection.")
+ (license license:lgpl2.1+)))