summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-11-16 09:34:27 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-16 09:34:27 +0100
commit154d97abdd16674fdebc763351f661bbcdc869a4 (patch)
tree0277a9380edd1390f16e432283d32499ffed36d1 /gnu/packages/glib.scm
parente4696c69d75f4fcf54c42beeb928032726bdaf7d (diff)
parent87e7faa2ae641d8302efc8b90f1e45f43f67f6da (diff)
downloadguix-patches-154d97abdd16674fdebc763351f661bbcdc869a4.tar
guix-patches-154d97abdd16674fdebc763351f661bbcdc869a4.tar.gz
Merge remote-tracking branch master into core-updates
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 62f09436a2..8c3a077e0d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -199,7 +199,10 @@ shared NFS home directories.")
("perl" ,perl) ; needed by GIO tests
("tzdata" ,tzdata-for-tests))) ; for tests/gdatetime.c
(arguments
- `(#:phases
+ `(;; TODO: Uncomment on the next rebuild cycle.
+ ;; #:disallowed-references (,tzdata-for-tests)
+
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-dbus-launch-path
(lambda* (#:key inputs #:allow-other-keys)
@@ -716,6 +719,33 @@ useful for C++.")
("pkg-config" ,pkg-config)
("python-pytest" ,python2-pytest)))))
+;; Newer version of this core-updates package, for Lollypop.
+(define-public python-pygobject-3.34
+ (package/inherit
+ python-pygobject
+ (version "3.34.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/pygobject/"
+ (version-major+minor version)
+ "/pygobject-" version ".tar.xz"))
+ (sha256
+ (base32 "06i7ynnbvgpz0gw09zsjbvhgcp5qz4yzdifw27qjwdazg2mckql7"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'delete-broken-tests
+ (lambda _
+ (with-directory-excursion "tests"
+ (for-each
+ delete-file
+ ;; FIXME: these tests require Gdk and/or Gtk 4.
+ '("test_atoms.py"
+ "test_overrides_gtk.py")))
+ #t)))))))
+
(define-public perl-glib
(package
(name "perl-glib")