summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-11-02 15:33:08 -0400
committerKei Kebreau <kkebreau@posteo.net>2017-11-02 15:37:22 -0400
commit13fbd174b5ffe5c2cc59e637f7859d357ab33d97 (patch)
tree105ed1a734669952d7285e605c67f3312a48f33f /gnu/packages/glib.scm
parent67bd376b1a45249d0b1b1477e32638a984aebd70 (diff)
downloadguix-patches-13fbd174b5ffe5c2cc59e637f7859d357ab33d97.tar
guix-patches-13fbd174b5ffe5c2cc59e637f7859d357ab33d97.tar.gz
gnu: itstool: Update to 2.0.4.
* gnu/packages/glib.scm (itstool): Update to 2.0.4. [inputs]: Replace python and python-libxml2 with python-2 and python2-libxml2.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 8e799718f7..fb5ab6b9b0 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -395,29 +395,28 @@ The intltool collection can be used to do these things:
(define itstool
(package
(name "itstool")
- (version "2.0.2")
+ (version "2.0.4")
(source (origin
(method url-fetch)
(uri (string-append "http://files.itstool.org/itstool/itstool-"
version ".tar.bz2"))
(sha256
(base32
- "0fh34wi52i0qikgvlmrcpf1vx6gc1xqdad4539l4d9hikfsrz45z"))))
+ "0q7b4qrc758zfx3adsgvz0r93swdbxjr42w37rahngm33nshihlp"))))
(build-system gnu-build-system)
(inputs
`(("libxml2" ,libxml2)
- ("python2-libxml2" ,python2-libxml2)
- ("python-2" ,python-2)))
+ ("python-libxml2" ,python-libxml2)
+ ("python" ,python)))
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after
- 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((prog (string-append (assoc-ref outputs "out")
- "/bin/itstool")))
- (wrap-program prog
- `("PYTHONPATH" = (,(getenv "PYTHONPATH"))))))))))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/itstool")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH"))))))))))
(home-page "http://www.itstool.org")
(synopsis "Tool to translate XML documents with PO files")
(description