summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-18 16:05:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-18 19:50:01 +0200
commit0e47fcced442d8e7c1b05184fdc1c14f10ed04ec (patch)
tree4ae844bc0ec3c670f8697bdc24362c122fa718ad /gnu/packages/glib.scm
parente4b70bc55a538569465bcedee19d1f2607308e65 (diff)
parent8b1bde7bb3936a64244824500ffe60f123704437 (diff)
downloadguix-patches-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar
guix-patches-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 01683df8c5..7fcde85305 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -873,7 +873,7 @@ useful for C++.")
(native-inputs
`(("perl-extutils-depends" ,perl-extutils-depends)
("perl-extutils-pkgconfig" ,perl-extutils-pkgconfig)))
- (inputs
+ (propagated-inputs
`(("glib" ,glib)))
(home-page "https://metacpan.org/release/Glib")
(synopsis "Perl wrappers for the GLib utility and Object libraries")
@@ -884,6 +884,32 @@ these libraries are used as the foundation for many of the libraries that make
up the Gnome environment, and are used in many unrelated projects.")
(license license:lgpl2.1+)))
+(define-public perl-glib-object-introspection
+ (package
+ (name "perl-glib-object-introspection")
+ (version "0.049")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/X/XA/XAOC/"
+ "Glib-Object-Introspection-" version ".tar.gz"))
+ (sha256
+ (base32 "0mxg6pz8qfyipw0ypr54alij0c4adzg94f62702b2a6hkp5jhij6"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-extutils-depends" ,perl-extutils-depends)
+ ("perl-extutils-pkgconfig" ,perl-extutils-pkgconfig)))
+ (propagated-inputs
+ `(("gobject-introspection" ,gobject-introspection)
+ ("perl-cairo-gobject" ,perl-cairo-gobject)
+ ("perl-glib" ,perl-glib)))
+ (home-page "https://metacpan.org/dist/Glib-Object-Introspection")
+ (synopsis "Dynamically create Perl language bindings")
+ (description "Glib::Object::Introspection uses the gobject-introspection and
+libffi projects to dynamically create Perl bindings for a wide variety of
+libraries. Examples include gtk+, webkit, libsoup and many more.")
+ (license license:lgpl2.1+)))
+
(define telepathy-glib
(package
(name "telepathy-glib")