summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-12 12:55:12 +0200
committerMarius Bakke <marius@gnu.org>2020-06-12 12:55:12 +0200
commitfdd883509301845ddb4dc90e70e58b469afb5441 (patch)
treeccc4dea5805f7063cc66f8c89ddf3d73b1410547 /gnu/packages/gl.scm
parent9b043df7403a10b35b93d133aac796fd277a7339 (diff)
downloadguix-patches-fdd883509301845ddb4dc90e70e58b469afb5441.tar
guix-patches-fdd883509301845ddb4dc90e70e58b469afb5441.tar.gz
gnu: mesa: Replace with 20.0.8.
* gnu/packages/gl.scm (mesa-20.0.8): New variable. (mesa)[replacement]: New field.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 8a17f7dd65..828612eee1 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -234,6 +234,13 @@ also known as DXTn or DXTC) for Mesa.")
(package
(name "mesa")
(version "20.0.7")
+
+ ;; Mesa 20.0.5 through 20.0.7 has problems with some graphic drivers, so
+ ;; we need this newer version.
+ ;; https://gitlab.freedesktop.org/mesa/mesa/-/issues/2882
+ ;; https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4861
+ (replacement mesa-20.0.8)
+
(source
(origin
(method url-fetch)
@@ -439,6 +446,21 @@ device drivers allows Mesa to be used in many different environments ranging
from software emulation to complete hardware acceleration for modern GPUs.")
(license license:x11)))
+;; Replacement package to fix <https://gitlab.freedesktop.org/mesa/mesa/-/issues/2863>.
+(define mesa-20.0.8
+ (package
+ (inherit mesa)
+ (version "20.0.8")
+ (source (origin
+ (inherit (package-source mesa))
+ (uri (list (string-append "https://mesa.freedesktop.org/archive/"
+ "mesa-" version ".tar.xz")
+ (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
+ "mesa-" version ".tar.xz")))
+ (sha256
+ (base32
+ "0v0bfh3ay07s6msxmklvwfaif0q02kq2yhy65fdhys49vw8c1w3c"))))))
+
(define-public mesa-opencl
(package
(inherit mesa)