summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-02-03 09:14:43 +0000
committerChristopher Baines <mail@cbaines.net>2021-02-03 09:57:35 +0000
commite740cc614096e768813280c718f9e96343ba41b3 (patch)
tree25ade70a5d408be80f62f19c6511172aab7dcce5 /gnu/packages/gl.scm
parent1b9186828867e77af1f2ee6741063424f8256398 (diff)
parent63cf277bfacf282d2b19f00553745b2a9370eca0 (diff)
downloadguix-patches-e740cc614096e768813280c718f9e96343ba41b3.tar
guix-patches-e740cc614096e768813280c718f9e96343ba41b3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 96d48b6dc8..6f06d27977 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -250,7 +250,7 @@ also known as DXTn or DXTC) for Mesa.")
(base32
"14m09bk7akj0k02lg8fhvvzbdsashlbdsgl2cw7wbqfj2mhdqwh5"))
(patches
- (search-patches "mesa-skip-disk-cache-test.patch"))))
+ (search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)
(propagated-inputs
`(;; The following are in the Requires.private field of gl.pc.
@@ -777,7 +777,7 @@ OpenGL.")
(define-public glfw
(package
(name "glfw")
- (version "3.2.1")
+ (version "3.3.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/glfw/glfw"
@@ -785,7 +785,7 @@ OpenGL.")
"/glfw-" version ".zip"))
(sha256
(base32
- "09kk5yc1zhss9add8ryqrngrr16hdmc94rszgng135bhw09mxmdp"))))
+ "1izgc4r0ypxwwklfzj98ab4xqsjpb1wbsfdbivvxpmr95x8km8q8"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no test target
@@ -799,6 +799,7 @@ OpenGL.")
;; These are in 'Requires.private' of 'glfw3.pc'.
("libx11" ,libx11)
("libxrandr" ,libxrandr)
+ ("libxi" ,libxi)
("libxinerama" ,libxinerama)
("libxcursor" ,libxcursor)
("libxxf86vm" ,libxxf86vm)))