summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-12-15 15:42:15 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-01-03 18:31:04 +0100
commitbea58fa1599b0e579079a4008067b155e75800f3 (patch)
tree48bc2b79661db67627478c8d12b0e4355c1a0a7b /gnu/packages/gl.scm
parentaed6c010141a523d578c4e277fd5f7f62c47bc54 (diff)
downloadguix-patches-bea58fa1599b0e579079a4008067b155e75800f3.tar
guix-patches-bea58fa1599b0e579079a4008067b155e75800f3.tar.gz
gnu: Add mojoshader-cs.
* gnu/packages/gl.scm (mojoshader-cs): New variable.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 63e12efe06..194e141faf 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -42,6 +42,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
+ #:use-module (gnu packages mono)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
@@ -889,3 +890,41 @@ the shaders at runtime.")
(description "This is the last version of the mojoshader library with
the glProgramViewportFlip before it was replaced with glProgramViewportInfo.")
(license license:zlib))))
+
+(define-public mojoshader-cs
+ (let ((commit "10d0dba21ff1cfe332eb7de328a2adce01286bd7"))
+ (package
+ (name "mojoshader-cs")
+ (version (git-version "20191205" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FNA-XNA/MojoShader")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11mdhf3fmb9rsn2iv753gmb596j4dh5j2iipgw078vg0lj23rml7"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; No tests.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (invoke "make" "-C" "csharp")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "csharp/bin/MojoShader-CS.dll" (string-append out "/lib"))
+ #t))))))
+ (native-inputs
+ `(("mono" ,mono)))
+ (home-page "https://github.com/FNA-XNA/MojoShader")
+ (synopsis "C# wrapper for MojoShader")
+ (description
+ "Mojoshader-CS provides C# bindings for the Mojoshader library.
+The C# wrapper was written to be used for FNA's platform support. However, this
+is written in a way that can be used for any general C# application.")
+ (license license:zlib))))