summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-29 19:40:08 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-29 23:30:18 +0200
commit93ef8ca662fc3dce4e15977347baa0b9c50dd29e (patch)
tree553bdd89d543ac95bd5b7cb4e018083573d847a7 /gnu/packages/gl.scm
parent6e1f8d552b73e508bba47dedb5676ce5ccdcc398 (diff)
downloadguix-patches-93ef8ca662fc3dce4e15977347baa0b9c50dd29e.tar
guix-patches-93ef8ca662fc3dce4e15977347baa0b9c50dd29e.tar.gz
gnu: mesa: Do not pass an empty string argument to the build system.
This is a follow-up to commit 301b2e74f986385664153e6e770e238b351f5cf0. * gnu/packages/gl.scm (mesa)[arguments]: Return the empty list instead of an empty string for the non-matching case.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index cd82b17d15..9ed043c7ae 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -318,7 +318,7 @@ also known as DXTn or DXTC) for Mesa.")
((or "x86_64-linux" "i686-linux")
'("-Dvulkan-overlay-layer=true"))
(_
- '("")))
+ '()))
;; Also enable the tests.
"-Dbuild-tests=true"