summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-26 17:11:20 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-26 17:11:20 +0200
commit7097e98586df3110b80943a88c27804d65f214fa (patch)
tree2e244b9fc19acc569d6abd42306aaf013f02da0d /gnu/packages/gl.scm
parent15870cc08d20501e3526fa892111a43ae9e3e02f (diff)
parent4577f3c6b60ea100e521c246fb169d6c05214b20 (diff)
downloadguix-patches-7097e98586df3110b80943a88c27804d65f214fa.tar
guix-patches-7097e98586df3110b80943a88c27804d65f214fa.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index ad0c1a20e3..656eb02fe0 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1089,7 +1090,7 @@ is written in a way that can be used for any general C# application.")
(define-public glmark2
(package
(name "glmark2")
- (version "2020.04")
+ (version "2021.12")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1098,20 +1099,12 @@ is written in a way that can be used for any general C# application.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ywpzp0imi3f8iyp7d1739576zx2nsr3db5hp2as4yhflfyq1as2"))
- (modules '((guix build utils)))
- ;; Fix Python 3 incompatibility.
- (snippet
- '(begin
- (substitute* "wscript"
- (("(sorted\\()FLAVORS\\.keys\\(\\)(.*)" _ beginning end)
- (string-append beginning "list(FLAVORS)" end)))
- #t))))
- (build-system waf-build-system)
+ "1aydqbrg9i74s19rrdrsscx94m885yvc43v3sdqlgyh675ms98jb"))))
+ (build-system meson-build-system)
(arguments
'(#:tests? #f ; no check target
#:configure-flags
- (list (string-append "--with-flavors="
+ (list (string-append "-Dflavors="
(string-join '("x11-gl" "x11-glesv2"
"drm-gl" "drm-glesv2"
"wayland-gl" "wayland-glesv2")