summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-24 22:44:57 +0200
committerMarius Bakke <marius@gnu.org>2020-07-25 16:16:10 +0200
commit7033bd0e0081c97fd8d6111991b0d293274770b3 (patch)
tree39c652212533a2265a10c672d72e2a9b11afb0e1 /gnu/packages/gl.scm
parent5060b49336fb915ec8cef0e2e69ff861ac87aa9c (diff)
downloadguix-patches-7033bd0e0081c97fd8d6111991b0d293274770b3.tar
guix-patches-7033bd0e0081c97fd8d6111991b0d293274770b3.tar.gz
gnu: mesa: Update to 20.1.4.
* gnu/packages/gl.scm (mesa): Update to 20.1.4. [replacement]: Remove. (mesa-20.0.8): Remove variable.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm26
1 files changed, 2 insertions, 24 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index fb33bd7f6d..3542fdcc1b 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -233,14 +233,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "20.0.7")
-
- ;; Mesa 20.0.5 through 20.0.7 has problems with some graphic drivers, so
- ;; we need this newer version.
- ;; https://gitlab.freedesktop.org/mesa/mesa/-/issues/2882
- ;; https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4861
- (replacement mesa-20.0.8)
-
+ (version "20.1.4")
(source
(origin
(method url-fetch)
@@ -252,7 +245,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "0y517qpdg6v6dsdgzb365p03m30511sbyh8pq0mcvhvjwy7javpy"))
+ "1zlrczmmkcy42w332rfmlicihlnrxmkrnkpb21sl98725cf2f038"))
(patches
(search-patches "mesa-skip-disk-cache-test.patch"))))
(build-system meson-build-system)
@@ -446,21 +439,6 @@ device drivers allows Mesa to be used in many different environments ranging
from software emulation to complete hardware acceleration for modern GPUs.")
(license license:x11)))
-;; Replacement package to fix <https://gitlab.freedesktop.org/mesa/mesa/-/issues/2863>.
-(define mesa-20.0.8
- (package
- (inherit mesa)
- (version "20.0.8")
- (source (origin
- (inherit (package-source mesa))
- (uri (list (string-append "https://mesa.freedesktop.org/archive/"
- "mesa-" version ".tar.xz")
- (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
- "mesa-" version ".tar.xz")))
- (sha256
- (base32
- "0v0bfh3ay07s6msxmklvwfaif0q02kq2yhy65fdhys49vw8c1w3c"))))))
-
(define-public mesa-opencl
(package/inherit mesa
(name "mesa-opencl")