summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-01-25 15:21:09 -0500
committerLeo Famulari <leo@famulari.name>2021-01-25 15:40:55 -0500
commit68dd78e2e47248b3e1e7ba1807a92a8374b39097 (patch)
treed38564293f285d688a55b23e8a6424c6b26213b1 /gnu/packages/gl.scm
parent8b55544212a90b0276df49596a3d373e5c2e8f5c (diff)
parent3f0af15131e524891df8c9f013f1be1597fe2d7e (diff)
downloadguix-patches-68dd78e2e47248b3e1e7ba1807a92a8374b39097.tar
guix-patches-68dd78e2e47248b3e1e7ba1807a92a8374b39097.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 2612347913..e378474147 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -770,7 +770,7 @@ OpenGL.")
(define-public glfw
(package
(name "glfw")
- (version "3.2.1")
+ (version "3.3.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/glfw/glfw"
@@ -778,7 +778,7 @@ OpenGL.")
"/glfw-" version ".zip"))
(sha256
(base32
- "09kk5yc1zhss9add8ryqrngrr16hdmc94rszgng135bhw09mxmdp"))))
+ "1izgc4r0ypxwwklfzj98ab4xqsjpb1wbsfdbivvxpmr95x8km8q8"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no test target
@@ -792,6 +792,7 @@ OpenGL.")
;; These are in 'Requires.private' of 'glfw3.pc'.
("libx11" ,libx11)
("libxrandr" ,libxrandr)
+ ("libxi" ,libxi)
("libxinerama" ,libxinerama)
("libxcursor" ,libxcursor)
("libxxf86vm" ,libxxf86vm)))