summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-07-25 11:36:16 +0200
committerRutger Helling <rhelling@mykolab.com>2019-07-25 11:37:36 +0200
commit688d8f22e205cd2a551a83103b07fe247705961b (patch)
tree57a8ce3e7bd4a7ee1db01cdeb5aaa7a4593b863b /gnu/packages/gl.scm
parent9c0170a6e9892b5e08390a5c0acdf89e888b7137 (diff)
downloadguix-patches-688d8f22e205cd2a551a83103b07fe247705961b.tar
guix-patches-688d8f22e205cd2a551a83103b07fe247705961b.tar.gz
gnu: mesa: Correct configure flag.
* gnu/packages/gl.scm (mesa): Build the iris driver for the correct systems.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index a7f09b37a9..4c3da2ad03 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -286,9 +286,9 @@ also known as DXTn or DXTC) for Mesa.")
'(,@(match (%current-system)
((or "armhf-linux" "aarch64-linux")
;; TODO: Fix svga driver for aarch64 and armhf.
- '("-Dgallium-drivers=etnaviv,freedreno,iris,nouveau,r300,r600,swrast,tegra,v3d,vc4,virgl"))
+ '("-Dgallium-drivers=etnaviv,freedreno,nouveau,r300,r600,swrast,tegra,v3d,vc4,virgl"))
(_
- '("-Dgallium-drivers=nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
+ '("-Dgallium-drivers=iris,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
;; Enable various optional features. TODO: opencl requires libclc,
;; omx requires libomxil-bellagio
"-Dplatforms=x11,drm,surfaceless,wayland"