summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 03:11:15 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:42:57 -0400
commit51b491b049b921fbfee0b06fbdd61cf2137dc926 (patch)
treefebf4aedcf9c40578169a5db5aef3f46eb84e358 /gnu/packages/gl.scm
parent841ee2a878ed9a677d5e2272bf935748a8bc3014 (diff)
downloadguix-patches-51b491b049b921fbfee0b06fbdd61cf2137dc926.tar
guix-patches-51b491b049b921fbfee0b06fbdd61cf2137dc926.tar.gz
gnu: mesa-headers: Return #t from all phases.
* gnu/packages/gl.scm (mesa-headers)[arguments]: Return #t from the custom install phase.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 9930de87de..e01e46cdd1 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -413,10 +413,11 @@ from software emulation to complete hardware acceleration for modern GPUs.")
(delete 'build)
(delete 'check)
(replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (copy-recursively "include" (string-append
- (assoc-ref outputs "out")
- "/include")))))))))
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively "include" (string-append
+ (assoc-ref outputs "out")
+ "/include"))
+ #t)))))))
;;; The mesa-demos distribution contains non-free files, many files with no
;;; clear license information, and many demos that aren't useful for most