summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-05 19:37:00 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-05 19:47:01 +0200
commit4bed3b101253e5f82c6423f0eb55b307ec839f53 (patch)
tree823671fa5fbf04f9354f79fafcce471f287cd558 /gnu/packages/gl.scm
parentd4721ff1017b64e5242b09fd7b430665ec580524 (diff)
downloadguix-patches-4bed3b101253e5f82c6423f0eb55b307ec839f53.tar
guix-patches-4bed3b101253e5f82c6423f0eb55b307ec839f53.tar.gz
gnu: mesa: Disable failing test on i686.
* gnu/packages/gl.scm (mesa)[arguments]: Add phase when building for i686.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index cfa392191a..3680a8979d 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -328,6 +328,15 @@ also known as DXTn or DXTC) for Mesa.")
(substitute* "src/intel/genxml/gen_pack_header.py"
(("/usr/bin/env python2") (which "python")))
#t))
+ ,@(if (string-prefix? "i686" (%current-system))
+ ;; Disable new test from Mesa 19 that fails on i686. Upstream
+ ;; report: <https://bugs.freedesktop.org/show_bug.cgi?id=110612>.
+ `((add-after 'unpack 'disable-failing-test
+ (lambda _
+ (substitute* "src/gallium/tests/unit/meson.build"
+ (("'u_format_test',") ""))
+ #t)))
+ '())
(add-before
'configure 'fix-dlopen-libnames
(lambda* (#:key inputs outputs #:allow-other-keys)