summaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-04-27 22:37:00 -0400
committerLeo Famulari <leo@famulari.name>2018-04-30 21:07:58 -0400
commitf62633ca2d4c6b3f3e54b56797dd07135571f372 (patch)
treeb109957ccb7554fa42562bb624969228203f87b7 /gnu/packages/gimp.scm
parent6d161406659fd9166da81162db8b2f42de1cd50b (diff)
downloadguix-patches-f62633ca2d4c6b3f3e54b56797dd07135571f372.tar
guix-patches-f62633ca2d4c6b3f3e54b56797dd07135571f372.tar.gz
gnu: gegl: Update to 0.4.
* gnu/packages/gimp.scm (gegl): Update to 0.4. [inputs]: Move babl and glib to propagated-inputs. [propagated-inputs]: Add json-glib. [arguments]: Re-enable the tests and remove the obsolete 'pre-build' phase. [source]: Use HTTPS URL. * gnu/packages/patches/gegl-CVE-2012-4433.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm36
1 files changed, 9 insertions, 27 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 0f27ceb44e..64fe04b4f9 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -77,43 +77,25 @@ provided, as well as a framework to add new color models and data types.")
(define-public gegl
(package
(name "gegl")
- (version "0.2.0")
+ (version "0.4.0")
(source (origin
(method url-fetch)
- (uri (list (string-append "http://download.gimp.org/pub/gegl/"
+ (uri (list (string-append "https://download.gimp.org/pub/gegl/"
(string-take version 3)
"/" name "-" version ".tar.bz2")))
(sha256
(base32
- "09nlv06li9nrn74ifpm7223mxpg0s7cii702z72cpbwrjh6nlbnz"))
- (patches (search-patches "gegl-CVE-2012-4433.patch"))))
+ "1ighk4z8nlqrzyj8w97s140hzj59564l3xv6fpzbr97m1zx2nkfh"))))
(build-system gnu-build-system)
(arguments
- '(;; More than just the one test disabled below now fails; disable them
- ;; all according to the rationale given below.
- #:tests? #f
- #:configure-flags '("LDFLAGS=-lm")
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'pre-build
- (lambda _
- ;; This test program seems to crash on exit. Specifically, whilst
- ;; g_object_unreffing bufferA and bufferB - This seems to be a bug
- ;; in the destructor. This is just a test program so will not have
- ;; any wider effect, although might be hiding another problem.
- ;; According to advice received on irc.gimp.org#gegl although 0.2.0
- ;; is the latest released version, any bug reports against it will
- ;; be ignored. So we are on our own.
- (substitute* "tools/img_cmp.c"
- (("g_object_unref \\(buffer.\\);") ""))
-
- (substitute* "tests/compositions/Makefile"
- (("/bin/sh") (which "sh")))
- #t)))))
- (inputs
+ '(#:configure-flags '("LDFLAGS=-lm")))
+ ;; These are propagated to satisfy 'gegl-0.4.pc'.
+ (propagated-inputs
`(("babl" ,babl)
("glib" ,glib)
- ("cairo" ,cairo)
+ ("json-glib" ,json-glib)))
+ (inputs
+ `(("cairo" ,cairo)
("pango" ,pango)
("libpng" ,libpng)
("libjpeg" ,libjpeg-8)))