summaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-28 15:05:38 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-28 22:27:11 +0100
commitef0552087339666ad3dfb3394ddefcc4648bef40 (patch)
treeb0690c08804d1c3662bcb73ac53c778a5f3c0490 /gnu/packages/gimp.scm
parent4c9438c0831ecb09874052c43d0df4101cd38126 (diff)
downloadguix-patches-ef0552087339666ad3dfb3394ddefcc4648bef40.tar
guix-patches-ef0552087339666ad3dfb3394ddefcc4648bef40.tar.gz
gnu: gegl: Extend test time-outs.
* gnu/packages/gimp.scm (gegl)[arguments]: Add an 'extend-test-time-outs phase.
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index ff986c0a02..c0c66e52f5 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -223,7 +223,22 @@ provided, as well as a framework to add new color models and data types.")
(build-system meson-build-system)
(arguments
`(#:configure-flags
- (list "-Dintrospection=false")))
+ (list "-Dintrospection=false")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'extend-test-time-outs
+ (lambda _
+ ;; Multiply some poorly-chosen time-outs for busy build machines.
+ (substitute* "tests/simple/test-node-exponential.c"
+ (("G_TIME_SPAN_SECOND" match)
+ (string-append "10 * " match)))
+ (substitute* "tests/simple/test-buffer-sharing.c"
+ (("g_timeout_add_seconds\\([0-9]+" match)
+ (string-append match "0")))
+ (substitute* (find-files "tests" "^meson\\.build$")
+ (("timeout ?: [0-9]+" match)
+ (string-append match "0")))
+ #t)))))
;; These are propagated to satisfy 'gegl-0.4.pc'.
(propagated-inputs
`(("babl" ,babl)