summaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-20 13:36:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-20 16:35:54 +0200
commitcb4baa4da6a36729b1495fa4241d8a64a95f6a56 (patch)
treef50fdacca4791a89337b6f55aeee70f8b52c46d5 /gnu/packages/gimp.scm
parent0f83d6029e500727c885e421cc4b30b072d15172 (diff)
downloadguix-patches-cb4baa4da6a36729b1495fa4241d8a64a95f6a56.tar
guix-patches-cb4baa4da6a36729b1495fa4241d8a64a95f6a56.tar.gz
gnu: gimp: Report bugs to Guix.
Upstream prints this when running ./configure. Take the hint. NOTE: if you plan on packaging GIMP for distribution, it is recommended to override the bug report URL with option: --with-bug-report-url=https://example.com/ so that you can filter packaging bugs from core bugs before reporting upstream. * gnu/packages/gimp.scm (gimp)[arguments]: Customise bug report URI.
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 9b02327990..df8f242c7a 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -130,9 +130,12 @@ buffers.")
(outputs '("out"
"doc")) ; 9 MiB of gtk-doc HTML
(arguments
- '(#:configure-flags (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))
+ '(#:configure-flags
+ (list (string-append "--with-html-dir="
+ (assoc-ref %outputs "doc")
+ "/share/gtk-doc/html")
+ ;; ./configure requests not to annoy upstream with packaging bugs.
+ "--with-bug-report-url=https://bugs.gnu.org/guix")
#:phases
(modify-phases %standard-phases
(add-after 'install 'install-sitecustomize.py