summaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 01:27:46 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:44 -0400
commit5f2c56e739d03ba418dadb7f4dcb0bfb5f7ffd38 (patch)
tree5865d6c6e9e054ec1b067773fb2abadb77fc0fbe /gnu/packages/gimp.scm
parent8d71e5b2a5b5f5e6ca49e10a65384c298437b401 (diff)
downloadguix-patches-5f2c56e739d03ba418dadb7f4dcb0bfb5f7ffd38.tar
guix-patches-5f2c56e739d03ba418dadb7f4dcb0bfb5f7ffd38.tar.gz
gnu: glimpse: Drop Python 2 support.
* gnu/packages/gimp.scm (glimpse)[source]: Fix indentation. [arguments]: Use gexps. [phases]{install-sitecustomize}: Delete phase. [native-inputs]: Use new style. [inputs]: Use new style. Delete python-2 and python2-pygtk.
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm104
1 files changed, 43 insertions, 61 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 2cf0a2b2d4..1bf396670e 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -581,79 +581,61 @@ transferring the style of an image.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/glimpse-editor/Glimpse")
- (commit (string-append "v" version))))
+ (url "https://github.com/glimpse-editor/Glimpse")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"0drngj2xqzxfaag6pc4xjffiw003n4y43x5rb5bf4ziv1ac51dm9"))))
(build-system gnu-build-system)
(outputs '("out"
- "doc")) ; 9 MiB of gtk-doc HTML
+ "doc")) ; 9 MiB of gtk-doc HTML
(arguments
- '(#:configure-flags
- (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html")
- "--enable-gtk-doc"
+ (list
+ #:configure-flags
+ #~(list
+ (string-append "--with-html-dir=" #$output "/share/gtk-doc/html")
+ "--enable-gtk-doc"
- ;; Prevent the build system from running 'gtk-update-icon-cache'
- ;; which is not needed during the build because Guix runs it at
- ;; profile creation time.
- "ac_cv_path_GTK_UPDATE_ICON_CACHE=true"
+ ;; Prevent the build system from running 'gtk-update-icon-cache'
+ ;; which is not needed during the build because Guix runs it at
+ ;; profile creation time.
+ "ac_cv_path_GTK_UPDATE_ICON_CACHE=true"
- ;; Disable automatic network request on startup to check for
- ;; version updates.
- "--disable-check-update"
+ ;; Disable automatic network request on startup to check for
+ ;; version updates.
+ "--disable-check-update"
- ;; ./configure requests not to annoy upstream with packaging bugs.
- "--with-bug-report-url=https://bugs.gnu.org/guix")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-sitecustomize.py
- ;; Install 'sitecustomize.py' into glimpse's python directory to
- ;; add pygobject and pygtk to pygimp's search path.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((pythonpath (getenv "GUIX_PYTHONPATH"))
- (out (assoc-ref outputs "out"))
- (sitecustomize.py
- (string-append
- out "/lib/glimpse/2.0/python/sitecustomize.py")))
- (call-with-output-file sitecustomize.py
- (lambda (port)
- (format port "import site~%")
- (format port "for dir in '~a'.split(':'):~%" pythonpath)
- (format port " site.addsitedir(dir)~%")))))))))
+ ;; ./configure requests not to annoy upstream with packaging bugs.
+ "--with-bug-report-url=https://bugs.gnu.org/guix")))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("gtk-doc" ,gtk-doc)
- ("intltool" ,intltool)
- ("libtool" ,libtool)
- ("libxslt" ,libxslt) ; for xsltproc
- ("pkg-config" ,pkg-config)
- ("glib:bin" ,glib "bin"))) ; for gdbus-codegen
+ (list autoconf
+ automake
+ gtk-doc
+ intltool
+ libtool
+ libxslt ;for xsltproc
+ pkg-config
+ `(,glib "bin"))) ;for gdbus-codegen
(inputs
- `(("babl" ,babl)
- ("glib" ,glib)
- ("glib-networking" ,glib-networking)
- ("libtiff" ,libtiff)
- ("libwebp" ,libwebp)
- ("libjpeg" ,libjpeg-turbo)
- ("atk" ,atk)
- ("gexiv2" ,gexiv2)
- ("gtk+" ,gtk+-2)
- ("libmypaint" ,libmypaint)
- ("mypaint-brushes" ,mypaint-brushes-1.3)
- ("exif" ,libexif) ; optional, EXIF + XMP support
- ("lcms" ,lcms) ; optional, color management
- ("librsvg" ,librsvg) ; optional, SVG support
- ("libxcursor" ,libxcursor) ; optional, Mouse Cursor support
- ("poppler" ,poppler) ; optional, PDF support
- ("poppler-data" ,poppler-data)
- ("python" ,python-2) ; optional, Python support
- ("python2-pygtk" ,python2-pygtk) ; optional, Python support
- ("gegl" ,gegl-for-glimpse))) ; XXX see comment in gegl-for-glimpse
+ (list babl
+ glib
+ glib-networking
+ libtiff
+ libwebp
+ libjpeg-turbo
+ atk
+ gexiv2
+ gtk+-2
+ libmypaint
+ mypaint-brushes-1.3
+ libexif ;optional, EXIF + XMP support
+ lcms ;optional, color management
+ librsvg ;optional, SVG support
+ libxcursor ;optional, Mouse Cursor support
+ poppler ;optional, PDF support
+ poppler-data
+ gegl-for-glimpse)) ;XXX see comment in gegl-for-glimpse
(home-page "https://glimpse-editor.github.io/")
(synopsis "Glimpse Image Editor")
(description "The Glimpse Image Editor is an application for image