summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-05-09 15:54:34 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-09 15:54:34 +0200
commiteb354bdacbf4154ec66038dac07f19bf4ced1fad (patch)
tree9c249bbfee46d43389d5e5618b5a8f3815132749 /gnu/packages/ghostscript.scm
parent958d25ad2a0f09cbc70d6d69c0f94180a2a77212 (diff)
downloadguix-patches-eb354bdacbf4154ec66038dac07f19bf4ced1fad.tar
guix-patches-eb354bdacbf4154ec66038dac07f19bf4ced1fad.tar.gz
gnu: ghostscript: Do not build the statically-linked 'gs' binary.
* gnu/packages/ghostscript.scm (ghostscript)[arguments]: Remove 'build-so' and 'install-so' phases. Replace 'build' and 'install' phases.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 8c3a99a04d..ae00eea1dc 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -173,12 +173,15 @@ printing, and psresize, for adjusting page sizes.")
(substitute* "base/gscdef.c"
(("GS_DOCDIR")
"\"~/.guix-profile/share/doc/ghostscript\""))))
- (add-after 'build 'build-so
- (lambda _
- (zero? (system* "make" "so"))))
- (add-after 'install 'install-so
- (lambda _
- (zero? (system* "make" "install-so")))))))
+ (replace 'build
+ (lambda _
+ ;; Build 'libgs.so', but don't build the statically-linked 'gs'
+ ;; binary (saves 18 MiB).
+ (zero? (system* "make" "so" "-j"
+ (number->string (parallel-job-count))))))
+ (replace 'install
+ (lambda _
+ (zero? (system* "make" "soinstall")))))))
(synopsis "PostScript and PDF interpreter")
(description
"Ghostscript is an interpreter for the PostScript language and the PDF