summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-05 10:45:56 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-05 10:45:56 +0200
commitc17b2adf541d24dab357f54b62e6399800534313 (patch)
treea7fe2b6bca24977006f823a2017e7e9b2f5b3cf2 /gnu/packages/ghostscript.scm
parent85345684d6b6ec1e3587a4a4e274463ba87a7968 (diff)
downloadguix-patches-c17b2adf541d24dab357f54b62e6399800534313.tar
guix-patches-c17b2adf541d24dab357f54b62e6399800534313.tar.gz
gnu: ghostscript: Use 'modify-phases'.
* gnu/packages/ghostscript.scm (ghostscript)[arguments]: Use 'modify-phases' instead of a chain of 'alist-cons-after'.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm30
1 files changed, 14 insertions, 16 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 0d45a992b2..3c18093eae 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -142,22 +143,19 @@ printing, and psresize, for adjusting page sizes.")
("tcl" ,tcl)))
(arguments
`(#:phases
- (alist-cons-after
- 'configure 'patch-config-files
- (lambda _
- (substitute* "base/all-arch.mak"
- (("/bin/sh") (which "bash")))
- (substitute* "base/unixhead.mak"
- (("/bin/sh") (which "bash"))))
- (alist-cons-after
- 'build 'build-so
- (lambda _
- (zero? (system* "make" "so")))
- (alist-cons-after
- 'install 'install-so
- (lambda _
- (zero? (system* "make" "install-so")))
- %standard-phases)))))
+ (modify-phases %standard-phases
+ (add-after 'configure 'patch-config-files
+ (lambda _
+ (substitute* "base/all-arch.mak"
+ (("/bin/sh") (which "bash")))
+ (substitute* "base/unixhead.mak"
+ (("/bin/sh") (which "bash")))))
+ (add-after 'build 'build-so
+ (lambda _
+ (zero? (system* "make" "so"))))
+ (add-after 'install 'install-so
+ (lambda _
+ (zero? (system* "make" "install-so")))))))
(synopsis "PostScript and PDF interpreter")
(description
"Ghostscript is an interpreter for the PostScript language and the PDF